Techniques et concepts de l'entreprise, de la finance et de l'économie 
(et fondements mathématiques)

Les carrés des écarts à la moyenne

logo

 

 

 

 

 

 

 

 

 

 

Somme des carrés des écarts à la moyenne

C’est une grandeur statistique de la plus haute utilité : la somme des carrés des écarts entre chaque observation d’une série statistique et la moyenne arithmétique de cette série. Elle permet notamment d'établir la variance. Mais comme son calcul ne présente aucune difficulté, elle ne fait jamais l’objet d’un paragraphe spécifique dans les manuels. Alors rendons-lui hommage sur ce site en lui réservant une page entière !

Celle-ci se décompose en deux parties : sa mise en œuvre sur tableur et la démonstration qu’il existe une autre façon de la calculer.

Construction avec Excel

Une entreprise de confection commercialise des costumes traditionnels. Le nombre de costumes vendus s’établit ainsi :

Mois Nombre de costumes
Janvier 25
Février 31
Mars 35
Avril 48
Mai 61
Juin 60
Juillet 52
Août 39
Septembre 38
Octobre 32
Novembre 29
Décembre 30

En bas de la colonne, ou d’ailleurs n’importe où sur la feuille mais nous la placerons en cellule B14, nous entrons la fonction Moyenne. Donc, =MOYENNE(B2 :B13).

Ajoutons une colonne qui indique le carré de l’écart entre la valeur du mois et la moyenne de la série (donc 40). La formule apparaît sur la capture d’écran ci-dessous en C2, =(B2-$B$14)^2. Avant de la cliquer-glisser vers le bas, il faut nommer la cellule B14 ou, comme ici, la fixer avec des $ (touche F4 lorsqu’on se positionne dessus pour l’intégrer à la formule).

tableau Excel

En C14, la somme des carrés à la moyenne (fonction =SOMME ou bouton Σ). Soit 1 670.

Une démonstration

Démontrons qu’une somme de carrés d’écarts à la moyenne est aussi égale à la somme des écarts multipliés par chaque valeur observée. Soit n le nombre d’observations.

=Somme(xi-m)xi

Vu comme ça, ce n’est pas évident et pourtant…

Au préalable, démontrons que :

somme écarts = 0

On peut aussi écrire…

autre formulation

On retrouve tout simplement la définition de la moyenne…

moyenne

Parfait. Reprenons le premier membre de l’égalité que nous devons démontrer.

somme des carrés

Développons.

développement

Commutativité de la somme :

commutativité

Dans le second terme, on sort la moyenne du sigma (puisque c’est un nombre réel) et on constate qu’il multiplie 0 (démontré ci-dessus). Donc le second terme est nul. CQFD.

fin de la démo

Pour l’illustrer, reprenons nos données. Nous retrouvons cette même somme de carrés des écarts à la moyenne, soit 1 670, mais en utilisant la seconde formule…

Mois Nombre de costumes
(1)
Écarts à la moyenne
(2) = (1) – 40
× nombre de costumes
(3) = (1) × (2)
Janvier 25 -15 -375
Février 31 -9 -279
Mars 35 -5 -175
Avril 48 8 384
Mai 61 21 1 281
Juin 60 20 1 200
Juillet 52 12 624
Août 39 -1 -39
Septembre 38 -2 -76
Octobre 32 -8 -256
Novembre 29 -11 -319
Décembre 30 -10 -300
Somme   0 1 670

 

 

© JY Baudot - Droits d'auteur protégés